[swift-evolution] [Pitch] String revision proposal #1

Ben Cohen ben_cohen at apple.com
Thu Mar 30 14:32:54 CDT 2017

> On Mar 30, 2017, at 8:59 AM, Adrian Zubarev via swift-evolution <swift-evolution at swift.org> wrote:
> We cannot rename SubSequence to Subsequence, because that would be odd compared to all other types containing Sequence.
There is a difference between subsequence, which is one word, and the others, which are noun phrases (i.e. “any sequence”, “lazy sequence”). The issue is whether it’s "sub-sequence" (capitalization reasonable) or subsequence (no reason for caps).

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20170330/5c181519/attachment.html>

More information about the swift-evolution mailing list