[swift-evolution] Pitch: Compound name `foo(:)` for nullary functions

Tino Heth 2th at gmx.de
Thu Feb 23 14:18:48 CST 2017

I never liked the compound name syntax because parenthesis are deeply connected to the application of function, and it breaks with the way selectors are specified in Objective-C.

If this topic is touched once again, imho it should be done thoroughly — with a syntax that can really eliminate all ambiguity.

Instead of
foo(bar:baz) as (String, Double) -> Void

I'd prefer something along the line of


More information about the swift-evolution mailing list