[swift-evolution] Add code to super methods.
2th at gmx.de
Thu Nov 17 04:54:50 CST 2016
An equivalent of "NS_REQUIRES_SUPER" (hopefully with a better name ;-) has been requested several times, but never got the momentum it deserves.
Considering the current confusion (especially in UIKit), it would be really nice to have some help from the compiler, and I wonder how composition and protocols would be helpful here at all.
I guess the problem is that there are to many options for this feature without an obvious favorite: Not only for the keywords, but also for the exact semantic.
Additionally, there are imho already to many access levels (private, fileprivate, internal, public, extendable?, open), so I hope we'll someday find a solution that is powerful enough to replace the special willSet/didSet treatment for properties as well.
So unless somebody has a real flash of genius, I guess it's better to delay discussion until there is a chance for new proposals to be accepted.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution