[swift-evolution] [swift-dev] SE-0111 related question

Chris Lattner clattner at apple.com
Thu Aug 18 13:25:55 CDT 2016

On Aug 18, 2016, at 11:10 AM, Douglas Gregor via swift-evolution <swift-evolution at swift.org> wrote:
>> If we agree that parameter are part of the name, then it should behave just like a name. Specifying names shouldn't matter more than the name of the variable storing the closure. It seems to me, humbly, that the fact that part of the name is split and written closer to the parameters could be considered just as syntactic sugar. 
> We could invent a language extension there. The point of requiring the underscores in:
> 	let myAdd: (_ a: Int, _ b: Int) -> Int
> Is to allow for some future evolution here.

Right, FWIW, these ideas were discussed here, which is linked off the SE-0111 proposal.


More information about the swift-evolution mailing list