[swift-evolution] [Accepted] SE-0133: Rename flatten() to joined()
jtbandes at gmail.com
Wed Jul 27 16:59:50 CDT 2016
Does the core team have feedback on whether Collection<String>'s
joined(separator:) should have a default separator of "", or another
overload with no parameter?
On Wed, Jul 27, 2016 at 2:56 PM, Jacob Bandes-Storch <jtbandes at gmail.com>
> I'll get right on it. Thanks to everyone who provided great feedback
> during the review!
> On Wed, Jul 27, 2016 at 2:53 PM, Chris Lattner via swift-evolution <
> swift-evolution at swift.org> wrote:
>> Proposal Link:
>> The review of "SE-0133: Rename flatten() to joined()" ran from Active
>> review July 24…26. The proposal has been *accepted*.
>> This proposal had significant positive community feedback for aligning
>> common operation names, but raised questions about whether ‘flatten’ was
>> term of art, and what it would mean for related operations like ‘flatMap’.
>> The core team discussed both sides of this debate, and decided it is best
>> to rename ‘flatten’ to ‘joined’, but keep ‘flatMap’ as it is, to preserve
>> its term of art. The core team prefers that it remain a distinct overload
>> of joined(separator:) to preserve performance. It also requests that the
>> returned collection types (FlattenCollection and friends) be left as-is for
>> now, since they are not names commonly directly referenced, and we’d like
>> to keep the change minimal.
>> Thank you to Jacob Bandes-Storch for driving this discussion forward!
>> Time is short, we’d appreciate it if someone could implement this ASAP.
>> -Chris Lattner
>> Review Manager
>> swift-evolution mailing list
>> swift-evolution at swift.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution