[swift-evolution] [SHORT Review] SE-0132: Rationalizing Sequence end-operation names

Jose Cheyo Jimenez cheyo at masters3d.com
Tue Jul 26 23:27:06 CDT 2016



On Jul 25, 2016, at 8:17 AM, Jose Cheyo Jimenez <cheyo at masters3d.com> wrote:

>> On Jul 24, 2016, at 11:10 PM, Chris Lattner via swift-evolution <swift-evolution at swift.org> wrote:
>> 
>> Hello Swift community,
>> 
>> The review of "SE-0132: Rationalizing Sequence end-operation names" begins now and runs through July 26.  Apologies for the short review cycle, but we’re right up against the end of source breaking changes for Swift 3.  The proposal is available here:
>> 
>>   https://github.com/apple/swift-evolution/blob/master/proposals/0132-sequence-end-ops.md
>> 
>> Reviews are an important part of the Swift evolution process. All reviews should be sent to the swift-evolution mailing list at
>> 
>>   https://lists.swift.org/mailman/listinfo/swift-evolution
>> 
>> or, if you would like to keep your feedback private, directly to the review manager.
>> 
>> What goes into a review?
>> 
>> The goal of the review process is to improve the proposal under review through constructive criticism and contribute to the direction of Swift. When writing your review, here are some questions you might want to answer in your review:
>> 
>>   * What is your evaluation of the proposal?
> 
> +1 
> 
I got to add that while I do like the renaming section of the proposal I do have reservations about RangeExpression and IncompleteRange. 

I think these additions will make index based operations harder to discover by autocomplete. Unnecessary feels like ranges would get much complicated and I feel that is a regression from the simplification treatment that they just received. They don't feel swifty to me. :)

-1 for IncompleteRange 
-1 collection[to/through/from]  // don't like this much. 
-1 for RangeExpression

Perhaps something similar could be introduced later but I think the proposal just stick to just renaming like it claims in the scope section. 

> In the future section :
> 
> I strongly dislike every(where:) but I would not be opposed to select(where:) but I think filter, map, reduce etc are way better names. 
> 
> 
>>   * Is the problem being addressed significant enough to warrant a change to Swift?
> 
> Yes. There was too much inconsistency.  
> 
> 
>>   * Does this proposal fit well with the feel and direction of Swift?
> Yes
>>   * If you have used other languages or libraries with a similar feature, how do you feel that this proposal compares to those?
>>   * How much effort did you put into your review? A glance, a quick reading, or an in-depth study?
> 
> Quick study. 
>> 
>> More information about the Swift evolution process is available at
>> 
>>   https://github.com/apple/swift-evolution/blob/master/process.md
>> 
>> Thank you,
>> 
>> -Chris Lattner
>> Review Manager
>> _______________________________________________
>> swift-evolution mailing list
>> swift-evolution at swift.org
>> https://lists.swift.org/mailman/listinfo/swift-evolution


More information about the swift-evolution mailing list