[swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

Xiaodi Wu xiaodi.wu at gmail.com
Mon Jul 25 01:34:55 CDT 2016


On Mon, Jul 25, 2016 at 1:10 AM, Chris Lattner via swift-evolution <
swift-evolution at swift.org> wrote:

> Hello Swift community,
>
> The review of "SE-0133: Rename `flatten()` to `joined()`" begins now and
> runs through July 26.  Apologies for the short review cycle, but we’re
> right up against the end of source breaking changes for Swift 3.  The
> proposal is available here:
>
>
> https://github.com/apple/swift-evolution/blob/master/proposals/0133-rename-flatten-to-joined.md
>
> Reviews are an important part of the Swift evolution process. All reviews
> should be sent to the swift-evolution mailing list at
>
>         https://lists.swift.org/mailman/listinfo/swift-evolution
>
> or, if you would like to keep your feedback private, directly to the
> review manager.
>
> What goes into a review?
>
> The goal of the review process is to improve the proposal under review
> through constructive criticism and contribute to the direction of Swift.
> When writing your review, here are some questions you might want to answer
> in your review:
>
>         * What is your evaluation of the proposal?
>

+1. A sensible simplification of the public API. Moreover, `flatten()` was
apparently treated as a term-of-art and doesn't observe the noun/verb
guidelines for non-mutating vs. mutating methods. So `joined()` is the
superior choice.


>         * Is the problem being addressed significant enough to warrant a
> change to Swift?
>

Sure; unnecessary inconsistency in the stdlib APIs are best reduced or
eliminated where possible.


>         * Does this proposal fit well with the feel and direction of Swift?
>

Yes.


>         * If you have used other languages or libraries with a similar
> feature, how do you feel that this proposal compares to those?
>

It reminds me of Python `join`, although in that language the default
separator for joining strings is " ". Arguably, a more convenient default
for Western languages, but a more universally appropriate default would
indeed be "" as proposed.


>         * How much effort did you put into your review? A glance, a quick
> reading, or an in-depth study?
>

A quick reading, but followed the original discussion.


>
> More information about the Swift evolution process is available at
>
>         https://github.com/apple/swift-evolution/blob/master/process.md
>
> Thank you,
>
> -Chris Lattner
> Review Manager
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160725/07a269d4/attachment.html>


More information about the swift-evolution mailing list