[swift-evolution] [Draft][Proposal] Formalized Ordering

Matthew Johnson matthew at anandabits.com
Fri Jul 22 21:15:48 CDT 2016


> On Jul 22, 2016, at 9:04 PM, Dave Abrahams via swift-evolution <swift-evolution at swift.org> wrote:
> 
> 
> on Fri Jul 22 2016, Matthew Johnson <swift-evolution at swift.org <mailto:swift-evolution at swift.org>> wrote:
> 
>>> On Jul 22, 2016, at 8:37 PM, Xiaodi Wu via swift-evolution
>>> <swift-evolution at swift.org <mailto:swift-evolution at swift.org>> wrote:
>>> 
>>> On Fri, Jul 22, 2016 at 8:20 PM, Dave Abrahams via swift-evolution
>>> <swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>> 
>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>>
>>> wrote:
>>> 
>>> on Fri Jul 22 2016, Daniel Duan <daniel-AT-duan.org <http://daniel-at-duan.org/>> wrote:
>>> 
>>>>> On Jul 22, 2016, at 3:00 PM, Dave Abrahams via swift-evolution
>>>>> <swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>>
>>>>> wrote:
>>>>> 
>>>>> 
>>>>> on Fri Jul 22 2016, Daniel Duan
>>>>> <swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>
>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>>>
>>>>> wrote:
>>>>> 
>>>> 
>>>>>>> On Jul 22, 2016, at 11:05 AM, Dave Abrahams via swift-evolution
>>>>>>> <swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>
>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>>>
>>>>>>> wrote:
>>>>>>> 
>>>>>>> 
>>>>>>> on Thu Jul 21 2016, Duan
>>>>>> 
>>>>>>> <swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>
>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>>
>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>
>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>>>>
>>>>>>> wrote:
>>>>>>> 
>>>>>>>> Great proposal. I want to second that areSame may mislead user to
>>>>>>>> think this is about identity.
>>>>>>>> 
>>>>>>>> I like areEquivalent() but there may be better names.
>>>>>>> 
>>>>>>> It really *is* about identity as I posted in a previous message.  But
>>>>>>> that doesn't change the fact that areEquivalent might be a better name.
>>>>>>> It's one of the things we considered; it just seemed long for no real
>>>>>>> benefit.
>>>>>>> 
>>>>>> 
>>>>>> If the addresses of the arguments aren’t being used, then we don’t consider
>>>>>> them part of their *identity*. I can follow this logic. My fear is most users
>>>>>> won’t make this leap on their own and get the same initial impression as I did.
>>>>>> It's entirely possible this fear is unfounded. Some educated bikesheding
>>>>>> wouldn't hurt here IMO :)
>>>>> 
>>>>> Well, it's still a very real question whether we ought to have the
>>>>> additional API surface implied by areSame, or wether we should collapse
>>>>> it with ===.
>>>>> 
>>>> 
>>>> To spell this out (because I had to think about it for a second): === will be derived from
>>>> <=>,
>>>> but also becomes default implementation for ==, which remains open for
>>>> customization.
>>> 
>>> I was imagining roughly this (untested):
>>> 
>>>  /// Two references are identical if they refer to the same
>>>  /// instance.
>>>  ///
>>>  /// - Note: Classes with a more-refined notion of “identical”
>>>  ///   should conform to `Identifiable` and implement `===`.
>>>  func ===(lhs: AnyObject, rhs: AnyObject) -> Bool {
>>>    ObjectIdentifier(lhs) == ObjectIdentifier(rhs)
>>>  }
>>> 
>>>  /// Supports testing that two values of `Self` are identical
>>>  ///
>>>  /// If `a` and `b` are of type `Self`, `a === b` means that
>>>  /// `a` and `b` are interchangeable in most code.  A conforming
>>>  /// type can document that specific observable characteristics
>>>  /// (such as the `capacity` of an `Array`) are inessential and
>>>  /// thus not to be considered as part of the interchangeability
>>>  /// guarantee.
>>>  ///
>>>  /// - Requires: `===` induces an equivalence relation over
>>>  ///   instances.
>>>  /// - Note: conforming types will gain an `==` operator that
>>>  ///   forwards to `===`.
>>>  /// - Note: Types that require domain-specific `==`
>>>  ///   implementations with different semantics (e.g. floating
>>>  ///   point) should define a more-specific overload of `==`,
>>>  ///   which will be used in contexts where the static type is
>>>  ///   known to the compiler.
>>>  /// - Note: Generic code should usually use `==` to compare
>>>  ///   conforming instances; that will always dispatch to `===`
>>>  ///   and will be unaffected by more specific overloads of
>>>  ///   `==`.
>>>  protocol Identifiable { // née Equatable name is negotiable
>>>    func ===(_: Self, _: aSelf) -> Bool
>>>  }
>>> 
>>>  /// Default definition of `==` for Identifiable types.
>>>  func ==<T: Identifiable>(lhs: T, rhs: T) -> Bool {
>>>    return lhs === rhs
>>>  }
>>> 
>>>  /// Conforming types have a default total ordering.
>>>  ///
>>>  /// If `a` and `b` are of type `Self`, `a <=> b` means that
>>>  /// `a` and `b` are interchangeable in most code.  A conforming
>>>  /// type can document that specific observable characteristics
>>>  /// (such as the `capacity` of an `Array`) are inessential and
>>>  /// thus not to be considered as part of the interchangeability
>>>  /// guarantee.
>>>  ///
>>>  /// - Requires: `<=>` induces a total ordering over
>>>  ///   instances.
>>>  /// - Requires: the semantics of `<=>` are  consistent with
>>>  ///   those of `===`.  That is, `(a <=> b) == .equivalent`
>>>  ///   iff `a === b`.
>>> 
>>> For floating point, I'd hope that `a === b` if `(a <=> b) == .same` *but not iff*. This is to satisfy IEEE 754: "Comparisons shall ignore the sign of zero (so +0 = −0)”.
>> 
>> The point of this design is that `===` means identity and that `.same ` also means identity.
>> 
>> Since this is new territory I suppose we get to decide what identity
>> means for floating point.  Should +0 and -0 have the same identity or
>> not?  I’ll leave the answer to folks more knowledgable about numerics
>> than I.
> 
> It's settled law 
> https://en.wikipedia.org/wiki/IEEE_floating_point#Total-ordering_predicate <https://en.wikipedia.org/wiki/IEEE_floating_point#Total-ordering_predicate>
> :-)

Yes, assuming we want to define identity in terms of the IEEE definition of total ordering.

> 
>> 
>> 
>>> 
>>>  /// - Note: conforming types will gain `<`, `<=`, `>`, and `>=`
>>>  ///   operators defined in terms of `<=>`.
>>>  /// - Note: Types that require domain-specific `<`, etc.
>>>  ///   implementations with different semantics (e.g. floating
>>>  ///   point) should define more-specific overloads of those
>>>  ///   operators, which will be used in contexts where the
>>>  ///   static type is known to the compiler.
>>>  /// - Note: Generic code can freely use `<=>` or the traditional
>>>  ///   comparison operators to compare conforming instances;
>>>  ///   the result will always be supplied by `<=>`
>>>  ///   and will be unaffected by more specific overloads of
>>>  ///   the other operators.
>>>  protocol Comparable : Identifiable {
>>>    func <=> (lhs: Self, rhs: Self) -> Ordering
>>>  }
>>> 
>>>  /// Default implementations of `<`, `<=`, `>`, and `>=`.
>>>  extension Comparable {
>>>    static func <(lhs: Self, rhs: Self) -> Bool {
>>>      return (lhs <=> rhs) == .ascending
>>>    }
>>>    static func <=(lhs: Self, rhs: Self) -> Bool {
>>>      return (rhs <=> lhs) != .ascending
>>>    }
>>>    static func >(lhs: Self, rhs: Self) -> Bool {
>>>      return (lhs <=> rhs) == .descending
>>>    }
>>>    static func >=(lhs: Self, rhs: Self) -> Bool {
>>>      return (rhs <=> lhs) != .descending
>>>    }
>>>  }
>>> 
>>>> I like this idea. If we keep === as a separate thing, now users have 3 “opportunities” to define
>>>> equality. The must be few, if any, use cases for this.
>>>> 
>>>> Would love to see if anyone on the list can give us an example. Otherwise we should make
>>>> areSame === again™!
>>>> 
>>>>>> 
>>>>>>>> Daniel Duan
>>>>>>>> Sent from my iPhone
>>>>>>>> 
>>>>>>>>> On Jul 21, 2016, at 6:32 PM, Robert Widmann via swift-evolution
>>>>>>>>> <swift-evolution at swift.org
>>>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>>
>>>>>>>>> wrote:
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>>> On Jul 21, 2016, at 6:19 PM, Xiaodi Wu
>>>>>>>>>> <xiaodi.wu at gmail.com <mailto:xiaodi.wu at gmail.com>
>>>>>>>>>> <mailto:xiaodi.wu at gmail.com <mailto:xiaodi.wu at gmail.com>>>
>>>>>>>>>> wrote:
>>>>>>>>>> 
>>>>>>>>>> This is nice. Is `areSame()` being proposed because static `==` is
>>>>>>>>>> the status quo and you're trying to make the point that `==` in the
>>>>>>>>>> future need not guarantee the same semantics?
>>>>>>>>> 
>>>>>>>>> Yep!  Equivalence and equality are strictly very different things.
>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>>>> Nit: I think the more common term in stdlib would be
>>>>>>>>>> `areEquivalent()`. Do you think `same` in that context (independent
>>>>>>>>>> of the word "ordering") might erroneously suggest identity?
>>>>>>>>> 
>>>>>>>>> There is room for improvement here.  Keep ‘em coming.
>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>>>>> On Thu, Jul 21, 2016 at 8:11 PM, Robert Widmann via
>>>>>>>>>>> swift-evolution
>>>>>>>>>>> <swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>>
>>>>>>>>>>> wrote:
>>>>>>>>>>> Hello Swift Community,
>>>>>>>>>>> 
>>>>>>>>>>> Harlan Haskins, Jaden Geller, and I have been working on a
>>>>>>>>>>> proposal to clean up the semantics of ordering relations in the
>>>>>>>>>>> standard library.  We have a draft that you can get as a gist.
>>>>>>>>>>> Any feedback you might have about this proposal helps - though
>>>>>>>>>>> please keeps your comments on Swift-Evolution and not on the gist.
>>>>>>>>>>> 
>>>>>>>>>>> Cheers,
>>>>>>>>>>> 
>>>>>>>>>>> ~Robert Widmann
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> _______________________________________________
>>>>>>>>>>> swift-evolution mailing list
>>>>>>>>>>> swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>
>>>>>>>>>>> https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
>>>>>>>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>>
>>>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> _______________________________________________
>>>>>>>>> swift-evolution mailing list
>>>>>>>>> swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>
>>>>>>>>> https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
>>>>>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>>
>>>>>>>> _______________________________________________
>>>>>>>> swift-evolution mailing list
>>>>>>>> swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>
>>>>>>>> https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
>>>>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>>
>>>>>>>> 
>>>>>>> 
>>>>>>> --
>>>>>>> Dave
>>>>>>> 
>>>>>>> _______________________________________________
>>>>>>> swift-evolution mailing list
>>>>>>> swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>
>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>
>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>>>
>>>>>>> https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
>>>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>>
>>>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
>>>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>>>
>>>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
>>>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>>
>>>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
>>>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>>>>
>>>>>> _______________________________________________
>>>>>> swift-evolution mailing list
>>>>>> swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>
>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>>
>>>>>> https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
>>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>>
>>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
>>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>>>
>>>>>> 
>>>>> 
>>>>> --
>>>>> Dave
>>>>> 
>>>>> _______________________________________________
>>>>> swift-evolution mailing list
>>>>> swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>
>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>>
>>>>> https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>>
>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
>>>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>>>
>>> 
>>> --
>>> Dave
>>> _______________________________________________
>>> swift-evolution mailing list
>>> swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>
>>> https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>>
>>> 
>>> _______________________________________________
>>> swift-evolution mailing list
>>> swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>>> <mailto:swift-evolution at swift.org <mailto:swift-evolution at swift.org>>
>>> https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
>>> <https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>>
>> _______________________________________________
>> swift-evolution mailing list
>> swift-evolution at swift.org <mailto:swift-evolution at swift.org>
>> https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
>> 
> 
> -- 
> Dave
> 
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org <mailto:swift-evolution at swift.org>
> https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160722/6194d10f/attachment.html>


More information about the swift-evolution mailing list