[swift-evolution] Discussion: Last chance to rename .self and .Self?
bknope at me.com
Fri Jul 15 14:34:51 CDT 2016
Thanks! I will take a look
> On Jul 15, 2016, at 3:28 PM, Adrian Zubarev via swift-evolution <swift-evolution at swift.org> wrote:
> You might have a look at our discussion thread. There is a huge overlap on your bikeshedding.
> Adrian Zubarev
> Sent with Airmail
> Am 15. Juli 2016 um 21:25:50, Brandon Knope via swift-evolution (swift-evolution at swift.org) schrieb:
>> July 27th is last day for breaking source changes for Swift 3...so I thought I would bring this up one final time.
>> - .self and .Self do not adequately convey what they do without some mental gymnastics
>> - self has somewhat two meanings (accessing a property on the type and getting the type of the object)
>> - We can get into a funky situation where we have self.someVar.self which looks odd (though symmetric!)
>> - What do we call these two selves? Postfix and prefix self? (I.e. Is it googleable?)
>> - rename to .type and .Type
>> - more bikeshedding? There has to be a better way to express these types other than .self and .Self
>> swift-evolution mailing list
>> swift-evolution at swift.org
> swift-evolution mailing list
> swift-evolution at swift.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution