[swift-evolution] [Accepted] SE-0118: Closure Parameter Names and Labels
clattner at apple.com
Wed Jul 13 22:14:33 CDT 2016
Proposal Link: https://github.com/apple/swift-evolution/blob/master/proposals/0118-closure-parameter-names-and-labels.md
The review of "SE-0118: Closure Parameter Names and Labels " ran from July 5...11, 2016. The proposal has been *accepted with modifications*:
The proposal has been very well received by the community and core team. The core team agrees with community contributions that "ManagedBuffer<Header,Element>.create(minimumCapacity: 10, makingValueWith: makeHeader)” should be renamed to “makingHeaderWith:”. The core team extensively discussed the name of "lines.split(whereSeparator: isAllWhitespace)” and agreed to keep the name as proposed, because the alternative name "lines.split(where: isAllWhitespace)” could be confusing given the behavior of dropping the “separator” from the result.
Thank you to Dave Abrahams, Dmitri Gribenko, and Maxim Moiseev for driving this discussion forward! I filed SR-2072 to track implementation of this feature.
More information about the swift-evolution