[swift-evolution] [Review] SE-0114: Updating Buffer "Value" Names to "Header" Names

Roth Michaels roth at rothmichaels.us
Wed Jul 6 13:00:55 CDT 2016

On Fri, Jul 01 2016 at 05:53:13 PM, Chris Lattner via swift-evolution <swift-evolution at swift.org> wrote:
> 	https://github.com/apple/swift-evolution/blob/master/proposals/0114-buffer-naming.md

> 	* What is your evaluation of the proposal?
+1; Header is much more clear than Value in describing the purpose of
the property.  I did have to double check the docs to be sure Header
meant what I thought it did---which made me wonder if Metadata would be
a more instructional name, but I do like Header.

> 	* Is the problem being addressed significant enough to warrant a
> 	change to Swift?

Yes, to me the Element array is the value of the buffer, so Value was a
bad name for this metadata property; Header is a much better name than Value.

> 	* Does this proposal fit well with the feel and direction of
> 	Swift?

Yes, increased clarity.

> 	* If you have used other languages or libraries with a similar
> feature, how do you feel that this proposal compares to those?

If have not dealt with this on a language level, but I have implemented
similar protocols at a user-framework level and would not use Value to
name this property.

> 	* How much effort did you put into your review? A glance, a
> quick reading, or an in-depth study?

Quick review, not much effort needed as it was simple to see the old
name was unclear and a poor description of the property.

Roth Michaels
roth at rothmichaels.us

More information about the swift-evolution mailing list