[swift-evolution] [swift-evolution-announce] [Review] SE-0114: Updating Buffer "Value" Names to "Header" Names

Austin Zheng austinzheng at gmail.com
Fri Jul 1 16:58:07 CDT 2016


> On Jul 1, 2016, at 2:53 PM, Chris Lattner <clattner at apple.com> wrote:
> The goal of the review process is to improve the proposal under review through constructive criticism and contribute to the direction of Swift. When writing your review, here are some questions you might want to answer in your review:
> 	* What is your evaluation of the proposal?

Strong +1.

"Header" much better describes the intended purpose of that portion of the buffer: as a way to store whatever pertinent metadata is necessary to manage the actual data being stored in the buffer. "Value" is generic enough (and similar enough in meaning to "Element") to be confusing, or at least largely meaningless.

> 	* Is the problem being addressed significant enough to warrant a change to Swift?

It's not a big problem, but it's not a big change either, so in the balance, yes.

> 	* Does this proposal fit well with the feel and direction of Swift?


> 	* If you have used other languages or libraries with a similar feature, how do you feel that this proposal compares to those?


> 	* How much effort did you put into your review? A glance, a quick reading, or an in-depth study?

I read the review, some of the pre-review discussion, and have been poking around the parts of the standard library that use ManagedBuffer (and similar internal-only types) to manage collection storage.

> More information about the Swift evolution process is available at
> 	https://github.com/apple/swift-evolution/blob/master/process.md
> Thank you,
> -Chris Lattner
> Review Manager
> _______________________________________________
> swift-evolution-announce mailing list
> swift-evolution-announce at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution-announce

More information about the swift-evolution mailing list