[swift-evolution] [Discussion] Rename BitwiseOperations protocol
rileytestut at gmail.com
Fri Jul 1 14:51:30 CDT 2016
This is probably very minor, but I’m not sure the protocol name “BitwiseOperations” fits the Swift API Design Guidelines. Here’s what the guidelines have to say about protocol names:
Protocols that describe what something is should read as nouns (e.g. Collection).
Protocols that describe a capability should be named using the suffixes able, ible, or ing (e.g. Equatable, ProgressReporting).
From these two, BitwiseOperations appears to be (attempting) to follow the first rule, yet “BitwiseOperations” doesn’t really describe what the type is, but rather that it can do bitwise operations. The documentation itself even describes the protocol as “a type that supports standard bitwise arithmetic operators."
I propose we rename it to “BitwiseOperable”, or something similar. Again, a small change, but if this were to ever happen, I think Swift 3 is the time.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution