[swift-evolution] [Review] SE-0101: Rename sizeof and related functions to comply with API Guidelines

Dave Abrahams dabrahams at apple.com
Thu Jun 30 18:05:43 CDT 2016

on Thu Jun 30 2016, Erica Sadun <erica-AT-ericasadun.com> wrote:

>> On Jun 30, 2016, at 4:41 PM, Dave Abrahams <dabrahams at apple.com> wrote:
>>> I mentioned this in a comment on the gist already, but I'm really not
>>> digging the "array" in `arraySpacing`. We've already moved from top-level
>>> "stride" to "memory layout spacing," gaining plenty of clarity. I'm
>>> skeptical that the "array" adds anything more. Moreover, it muddies the
>>> waters by mentioning a specific type (Array) in a context where you're
>>> querying the memory layout properties of another type.
>> OK, I agree with that.  If we have “alignment” rather than
>> “defaultAlignment,” I suppose we can have plain “spacing.”
> No way to last-second sell you on interval rather than spacing?

If you can explain why it's better.

> // Returns the least possible interval between distinct instances of
> /// `T` in memory.  The result is always positive.

For me, “interval” doesn't go with “size” and “alignment,” which are all
about physical distances and locations.  There are all kinds of
“intervals,” e.g. time intervals.


More information about the swift-evolution mailing list