[swift-evolution] [Discussion] Terms of Art Swiftification

Dave Abrahams dabrahams at apple.com
Mon Jun 27 14:44:11 CDT 2016

on Mon Jun 27 2016, Erica Sadun <swift-evolution at swift.org> wrote:

> Under consideration is the resolution that "some terms of art while
> appropriate to many FP languages, may be better served by using Swift
> names."
> Consider, for example, `filter(_:)`. Sean Heber writes,
>> Just tossing my vote in the hat for renaming .filter() to something
>> like .select() since that better matches what it does, IMO. “Filter”
>> is almost like the opposite word from what it should be since the
>> closure returning true is what decides what is included in the
>> results, not what is filtered *from* the results. I mean, yeah, I
>> can kind of understand the logic either way, but it’s always been
>> one of those strange mental gymnastics things."
> When asked "Shouldn't there be a term of art exemption for
> `filter(_:)`. Otherwise why not use `select(where:)`," Dave Abrahams
> replies:
>> Because `where(...)` is better.
> Have at it.

This discussion is already happening in

Do you really want to start over?


More information about the swift-evolution mailing list