[swift-evolution] [Question] Grand Renaming and Delegate/Datasource protocols !

Jerome ALVES j.alves at me.com
Mon Jun 27 11:54:06 CDT 2016


Hi everyone,

I can't find anything about Cocoa Delegate/Datasource protocol "Grand Renaming" for Swift 3
Is something planned about this ?

Because I find that actual names don't fit with Swift 3 API guidelines.

For instance : 

func numberOfSectionsInTableView(_ tableView: UITableView) -> Int
func tableView(_ tableView: UITableView, numberOfRowsInSection section: Int) -> Int
func tableView(_ tableView: UITableView, cellForRowAtIndexPath indexPath: NSIndexPath) -> UITableViewCell
func tableView(_ tableView: UITableView, moveRowAtIndexPath sourceIndexPath: NSIndexPath, toIndexPath destinationIndexPath: NSIndexPath)

func tableView(_ tableView: UITableView, heightForRowAtIndexPath indexPath: NSIndexPath) -> CGFloat
func tableView(_ tableView: UITableView, didSelectRowAtIndexPath indexPath: NSIndexPath)
...

could be renamed to something like this : 

func numberOfSections(in tableView: UITableView) -> Int
func numberOfRows(inSection section: Int, in tableView: UITableView) -> Int
func cellForRow(at indexPath: NSIndexPath, in tableView: UITableView) -> UITableViewCell
func moveRow(at sourceIndexPath: NSIndexPath, to destinationIndexPath: NSIndexPath, in tableView: UITableView)

func heightForRow(at indexPath: NSIndexPath, in tableView: UITableView) -> CGFloat
func didSelectRow(at indexPath: NSIndexPath, in tableView: UITableView)
...



Kind regards,

Jérôme Alves
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160627/e0657b34/attachment.html>


More information about the swift-evolution mailing list