[swift-evolution] [Proposal] Add floor() and ceiling() functions to FloatingPoint

Haravikk swift-evolution at haravikk.me
Mon Jun 27 04:59:52 CDT 2016

> On 27 Jun 2016, at 07:55, James Hillhouse <jdhillhouse4 at icloud.com> wrote:
>> On Jun 27, 2016, at 1:53 AM, Xiaodi Wu via swift-evolution <swift-evolution at swift.org <mailto:swift-evolution at swift.org>> wrote:
>> I disagree: in English, the nouns are floor and ceiling. That's what they should be called.
> Completely agree.

This is why I suggested roundedDown() and roundedUp() in place of floor() and ceiling(), as the latter are kind of strange terms to fit into Swift, they're not that explanatory to people that don't know them, and rounding up and down with precision greater than zero could also be useful operations. Plus it would group all rounding methods together.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160627/45c41904/attachment.html>

More information about the swift-evolution mailing list