[swift-evolution] [Returned for revision] SE-0077: Improved operator declarations

Anton Zhilin antonyzhilin at gmail.com
Sat Jun 25 10:33:32 CDT 2016

Xiaodi Wu via swift-evolution <swift-evolution at ...> writes:

> I mean, we have `protocol IteratorProtocol`, so this is par for the 
> precedencegroup RangePrecedence { ... }

Brandon sent me a bright idea: we should rename precedencegroup to 
precedence. Compare:

precedence RangePrecedence { ... }
protocol IteratorProtocol { ... }

This is not totally new, but Precedence suffix and comparison to protocols 
is what makes it shine. Anyone else like the idea?

More information about the swift-evolution mailing list