[swift-evolution] [Review] SE-0101: Rename sizeof and related functions to comply with API Guidelines
erica at ericasadun.com
Thu Jun 23 17:05:51 CDT 2016
> On Jun 22, 2016, at 1:32 PM, Dave Abrahams via swift-evolution <swift-evolution at swift.org> wrote:
> on Wed Jun 22 2016, Erica Sadun <swift-evolution at swift.org> wrote:
>>> On Jun 22, 2016, at 11:51 AM, Dave Abrahams via swift-evolution <swift-evolution at swift.org> wrote:
>>> on Wed Jun 22 2016, Erica Sadun <swift-evolution at swift.org> wrote:
>>>> No, I'd do edits on a gist page not in-place
>>> Then feel free, of course! It's your choice, y'know. I wouldn't want
>>> to ask you to propose something you don't believe in...
>> I believe the current approach needs improving. I am fine with both
>> approaches. You've more or less convinced me on a very good reason
>> why a less perfect solution is a better approach.
>> I just want to know if it would help going into the core team review
>> to have that rationale written up and formal in advance.
> I think it would. It would *really* help if someone would prepare a
> patch that uses both APIs so we could see how the resulting code looks
> in practice. :-)
Here you go: https://gist.github.com/erica/57a64163870486468180b8bab8a6294e <https://gist.github.com/erica/57a64163870486468180b8bab8a6294e>
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution