[swift-evolution] the "guard" keyword, again

Sean Heber sean at fifthace.com
Tue Jun 21 08:44:15 CDT 2016

> In the Commonly Rejected Changes page and in this swift-evolution email to which it refers, I read that first there was “unless", then “require” then finally “guard ... else”.
> I couldn’t find the earlier discussion in which “unless” was replaced for a while by “require”, so I am moved to ask, “Was there ever “require … else”, or was it just “require”? I’ll assume it was just “require”.

FYI the decisions and discussions that lead to “guard" occurred within Apple well before Swift was open sourced.


More information about the swift-evolution mailing list