[swift-evolution] [SE-0088] Dispatch API names
brent at architechies.com
Tue Jun 21 01:40:41 CDT 2016
> The guideline that methods should "read as imperative verb phrases" applies to the full name, labels and arguments and all, and not just the base name. You'll recall that the original proposal had .asynchronously(execute:), which is very much an imperative phrase. `.async(execute:)` was substituted by popular demand, with "async" being regarded as a term-of-art exception.
Right, I forgot about that. I had a vague feeling that `execute` was the verb, but the shortening obscured `async`'s role as an adverb.
More information about the swift-evolution