[swift-evolution] API Guidelines: dropFirst?
Jonathan Hull
jhull at gbis.com
Thu Jun 16 07:03:50 CDT 2016
…Thus, I don’t really see the harm in renaming these to match the rest of Swift. It won’t cause any confusion that can’t be easily recovered from. I was outvoted on that though…
Thanks,
Jon
> On Jun 16, 2016, at 5:01 AM, Jonathan Hull <jhull at gbis.com> wrote:
>
> I mean that *IF* we were to rename ‘map’ to ‘mapped’, the compiler would catch this and could recommend the new name. Even if we add a mutating version called ‘map’, it would still catch this case because the mutating version would have a void return.
>
> Thanks,
> Jon
>
>> On Jun 16, 2016, at 4:57 AM, Brent Royal-Gordon <brent at architechies.com> wrote:
>>
>>> The signatures are also different, so:
>>>
>>> let newList = list.map(…)
>>>
>>> would throw an error because I have the signature wrong.
>>
>> I'm not sure what you mean by this. What is the error? Why? Does it have something to do with the code you imagine is elided by the ellipses?
>>
>> --
>> Brent Royal-Gordon
>> Architechies
>>
>>
>
More information about the swift-evolution
mailing list