[swift-evolution] [Pitch] Renaming sizeof, sizeofValue, strideof, strideofValue
erica at ericasadun.com
Thu Jun 2 16:32:14 CDT 2016
> On Jun 2, 2016, at 3:28 PM, John McCall via swift-evolution <swift-evolution at swift.org> wrote:
>> On Jun 2, 2016, at 2:05 PM, Xiaodi Wu <xiaodi.wu at gmail.com <mailto:xiaodi.wu at gmail.com>> wrote:
>> On Thu, Jun 2, 2016 at 3:46 PM, John McCall via swift-evolution <swift-evolution at swift.org <mailto:swift-evolution at swift.org>> wrote:
> Yes, I think that it is clear that, even if we added a property on all types, it would not be acceptable to name that property something like "size"; it would have to be something longer like "storageSize".
Suggested names so far for augmenting the base:
* memorySize, memoryAlignment, memorySpacing/memoryStride
* storageSize, storageAlignment, storageSpacing/storageStride
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution