[swift-evolution] [Pitch] Renaming sizeof, sizeofValue, strideof, strideofValue
erica at ericasadun.com
Thu Jun 2 00:03:36 CDT 2016
> On Jun 1, 2016, at 10:55 PM, Xiaodi Wu <xiaodi.wu at gmail.com> wrote:
> On Wed, Jun 1, 2016 at 11:28 PM, Erica Sadun via swift-evolution <swift-evolution at swift.org <mailto:swift-evolution at swift.org>> wrote:
> Upon accepting SE-0098, the core team renamed the proposed stdlib function from dynamicType() to type(of:). They write, "The core team recognizes that this means that we should probably resyntax the existing sizeof/strideof functions, but that should be a follow-on discussion."
> Follow on discussion started. Have at it.
> See: http://thread.gmane.org/gmane.comp.lang.swift.evolution/15830 <http://thread.gmane.org/gmane.comp.lang.swift.evolution/15830>
And added alignof/alignofValue plus the original discussion thread
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution