[swift-evolution] [swift-evolution-announce] [Returned for revision] SE-0089: Renaming String.init<T>(_: T)
clattner at apple.com
Sat May 28 15:05:12 CDT 2016
> On May 27, 2016, at 9:36 PM, Brent Royal-Gordon via swift-evolution <swift-evolution at swift.org> wrote:
> I prefer the more conservative and backwards-compatible option of using `description` and conforming `ValuePreservingStringConvertible` to `CustomStringConvertible`.
> This is for three reasons:
+1 to all of your points.
> ("Lossless" instead of "ValuePreserving" is fine too, perhaps even slightly better.)
I agree, even though Lossless seems less specific, it does seem like it would feel more comfortable sitting next to “Custom”.
More information about the swift-evolution