[swift-evolution] [swift-evolution-announce] [Returned for revision] SE-0089: Renaming String.init<T>(_: T)

Dave Abrahams dabrahams at apple.com
Fri May 27 16:49:08 CDT 2016

on Thu May 26 2016, Patrick Smith <swift-evolution at swift.org> wrote:

>> On 27 May 2016, at 2:40 PM, Austin Zheng via swift-evolution <swift-evolution at swift.org> wrote:
>> Any of the NSObject subclass candidates may require their
>> `description`s to be altered to meet the semantics, which may or may
>> not be an acceptable breaking change.
> Do you think it might be worth changing `description` to be named
> something else? Something more clear, less likely to conflict with
> ‘real’ properties — ‘description’ doesn’t seem to portray something
> that is value-preserving. What is the reason for calling it
> ‘description’?

The main reason was backward compatibility with Cocoa, which already has
a “description” property.

> Especially if NSObject subclasses won’t fit, then why not have a
> different method that can be strictly value preserving? (Then
> `description` can stay being an NSObject thing.)


More information about the swift-evolution mailing list