[swift-evolution] [Accepted with Revision] SE-0088: Modernize libdispatch for Swift 3 naming conventions
clattner at apple.com
Thu May 19 22:57:12 CDT 2016
Proposal link: https://github.com/apple/swift-evolution/blob/master/proposals/0088-libdispatch-for-swift3.md
Hello Swift Community,
The review of "SE-0088: Modernize libdispatch for Swift 3 naming conventions" ran from May 10…17, 2016. The proposal is *accepted with revisions* for Swift 3.
The community and core team are both very positive about this massive improvement to the libdispatch APIs. Much of the discussion has centered around specific details in the proposal - for example the “.asynchronously” method on DispatchQueue. This great discussion leads to several requested revisions in the proposal:
- Rename the DispatchQueue.[a]synchronously methods to ".async” and ".sync”, to follow the term of art.
- Rename DispatchIO setHighWater, setLowWater --> setLimit(highWater:), setLimit(lowWater:)
- Rename setTargetQueue(queue:) and DispatchSource.setTimer
- Rename Semaphore, Group and WorkItem: .wait(timeout:) --> wait() and wait(withTimeout:)
- Expand source handler methods to take the same arguments as async()
- Expand DispatchQueue.after to take the same arguments as async() in addition to the when: argument
Thank you to Matt Wright proposing this, and for all of the implementation work that has gone into this so far!
More information about the swift-evolution