[swift-evolution] SE-0005 ==> Please keep well know acronyms capitalized!

charles@charlesism.com charlesism.com at gmail.com
Thu May 19 15:20:43 CDT 2016

I don't believe there's a correct answer here. Both urlHandler and URLHandler are bad names (for instances). Since we're stuck with camelCase, bad names are a fact of life.

Sent from my iPhone

> On May 19, 2016, at 11:56 AM, Pavel Kapinos via swift-evolution <swift-evolution at swift.org> wrote:
> Hi Brent,
> Thank you for you encouragement! Please join in to support it **now**!
> Cheers,
> Pavel.
>>> On May 19, 2016, at 11:53 AM, Brent Royal-Gordon <brent at architechies.com> wrote:
>>> SE-0005 "Better Translation of Objective-C APIs Into Swift Proposal” in Proposed Solution # 6 "Lowercase values" suggests “to lowercase non-prefixed values whenever they are imported” with an example of URLHandler property becoming urlHandler. Being long time Cocoa developer, I object to this particular example and would like to suggest to keep capitalized any well known acronyms, like ASCII, PDF, URL etc. as they are now in Cocoa. Thank you!
>> I and others fought and lost this particular battle back when the guidelines were being drafted. Just be glad you didn't end up with uppercase rules calling for things like `UrlComponents`.
>> -- 
>> Brent Royal-Gordon
>> Architechies
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution

More information about the swift-evolution mailing list