[swift-evolution] [Review] SE-0087: Rename lazy to @lazy

Jose Cheyo Jimenez cheyo at masters3d.com
Wed May 18 21:19:04 CDT 2016

> 	* What is your evaluation of the proposal?

-1. Too early to optimize this. I would also be opposed to renaming didSet/willSet to lowercased preemptively because of the sake of renaming. 
I think property behaviors should declare their own naming and syntax conventions (and be accepted in a version of Swift) before we start changing these API. 

> 	* Is the problem being addressed significant enough to warrant a change to Swift?

No because we do not know what property behaviors would look like for sure. 

> 	* Does this proposal fit well with the feel and direction of Swift?

> 	* If you have used other languages or libraries with a similar feature, how do you feel that this proposal compares to those?

> 	* How much effort did you put into your review? A glance, a quick reading, or an in-depth study?

I read this proposal and other mail treads about API that will be affected by property behaviors like didSet/ willSet and lazy 

More information about the swift-evolution mailing list