It is common to shadow optional value name with unwrapped value with same name: if let someGoodValue = someGoodValue {...} What if we'll have a syntax to not repeat the variable name to achieve the same target: if let someGoodValue! {...} What do you think?