[swift-evolution] [Accepted with modifications] SE-0045: Add scan, prefix(while:), drop(while:), and unfold to the stdlib

Dave Abrahams dabrahams at apple.com
Fri May 6 16:23:41 CDT 2016

on Fri May 06 2016, Kevin Ballard <swift-evolution at swift.org> wrote:

>     One idea that came out of the core team discussion was something like:
>     sequence(from: 0) { $0 += 42 }
>     Since it returns a sequence.
> It just occurred to me that, if we follow existing naming conventions, this
> function would end up returning a value of type SequenceSequence 😁.

Why do you think so?


More information about the swift-evolution mailing list