[swift-evolution] [swift-evolution-announce] [Accepted with modifications] SE-0045: Add scan, prefix(while:), drop(while:), and unfold to the stdlib

Pierre Grabolosa pierre.grabolosa at imerir.com
Thu May 5 16:23:52 CDT 2016

Most humbly, I think "expand" could be an interesting name for this operation. It seems it hasn't come up, but I could be wrong.

Best regards,

Sent from my iPhone

> On 05 May 2016, at 01:50, Chris Lattner <clattner at apple.com> wrote:
> unfold(_:applying:) - This addition is *rejected* by the core team as written, but deserves more discussion in the community, and potentially could be the subject of a future proposal.  The core team felt that the utility of this operation is high enough to be worth including in the standard library, but could not find an acceptable name for it.  “unfold” is problematic, despite its precedence in other language, because Swift calls the corresponding operation “reduce” and not “fold”.  No one could get excited about “unreduce”.   “iterate” was also considered, but a noun is more appropriate than an verb in this case.  Given the lack of a good name, the core team preferred to reject to let the community discuss it more.

More information about the swift-evolution mailing list