[swift-evolution] Trial balloon: conforming sizeof, sizeofValue, etc. to naming guidelines
shawnce at gmail.com
Sun May 1 12:08:03 CDT 2016
I personally kinda want to see these namespaced instead of global
functions. That could possibly allow clarity in naming.
On Sun, May 1, 2016 at 2:55 AM Brent Royal-Gordon via swift-evolution <
swift-evolution at swift.org> wrote:
> > With the renaming proposed above, stride(of:) will appear to be related
> to stride(from:to:by:). This conflict arises from a pre-existing issue;
> namely, the term "stride" is used to mean two different things. Although
> moving the preposition only highlights the issue, one possible resolution
> is to rename strideof(_:) to strideSize(of:) and strideofValue(_:)
> I wonder if it might make sense to rename all of these, then?
> Brent Royal-Gordon
> swift-evolution mailing list
> swift-evolution at swift.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution