[swift-evolution] [swift-evolution-announce] [Review] SE-0045: Add scan, prefix(while:), drop(while:), and iterate to the stdlib

Dave Abrahams dabrahams at apple.com
Fri Apr 29 17:34:39 CDT 2016

on Fri Apr 29 2016, Kevin Ballard <swift-evolution at swift.org> wrote:

> On Thu, Apr 28, 2016, at 02:13 PM, Pyry Jahkola via swift-evolution wrote:
>     I would really like a different name for scan. While it’s the term of art
>         for Haskell and co, it really seems meaningless to regular programmers
>         (why is “scanning” the way you produce an array of intermediate
>         reduces?), and it would be better to follow the pattern already
>         established elsewhere in the library to give friendlier names e.g.
>         flatMap instead of bind, reduce instead of fold.
>         I think Python calls it accumulate:
>         http://docs.python.org/3/library/itertools.html#itertools.accumulate
>     FWIW, Clojure calls it `reductions` which aligns pretty nicely with the
>     `reduce` counterpart.
> I like it.



More information about the swift-evolution mailing list