[swift-evolution] [Review] SE-0045: Add scan, prefix(while:), drop(while:), and iterate to the stdlib
erica at ericasadun.com
Fri Apr 29 09:17:56 CDT 2016
> On Apr 28, 2016, at 10:15 PM, Brent Royal-Gordon via swift-evolution <swift-evolution at swift.org> wrote:
> I believe that `prefix(while:)` and `dropFirst(while:)` would be most consistent with the current standard library, but frankly, I consider that an indictment of the current names.
> `skip` is better than `drop`, but they are both pigs; one's just wearing lipstick.
This is a great place to bring up "terms of art", again. When looking to other languages as our muse, trying to adapt syntax into Swift's tortured guidance system is less successful than retaining those terms, which have already been extensively bikeshedded in their original development. I much prefer takeWhile dropWhile, etc.
More information about the swift-evolution