[swift-evolution] [Accepted] SE-0059: Update API Naming Guidelines and Rewrite Set APIs Accordingly
dgregor at apple.com
Mon Apr 18 16:18:35 CDT 2016
Proposal link: https://github.com/apple/swift-evolution/blob/master/proposals/0059-updated-set-apis.md
Hello Swift Community,
The review of SE-0059 "Update API Naming Guidelines and Rewrite Set APIs Accordingly” ran from March 31...April 5, 2016. The proposal is accepted.
There was much debate, both before and during the review, over the “InPlace” suffix/ “form” prefix, and at this point any answer will be objectionable to some. The core team has opted to accept the proposal as-is, keeping the “form” prefix to describe the mutating counterpart to an operation naturally described by a noun (e.g., “formUnion” for the mutating variant of “union”), for the reasons described in the proposal itself. Thanks all for the spirited discussion!
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution