[swift-evolution] [Pitch] Rename `x.dynamicType` to `x.Self`
jgroff at apple.com
Fri Apr 15 12:19:42 CDT 2016
> On Apr 14, 2016, at 11:59 AM, Brandon Knope <bknope at me.com> wrote:
> -1 from me. To me this is not *obvious* as to what "Self" it means.
> And it seems possible to run into this:
> Just looks confusing to me. What's wrong with using "Type" or something more obvious?
That's a fair point. On the other hand, I think we're pretty consistent now about using CapitalizedCamelCase for types and lowerCamelCase for non-types, so while we could rename Self to SelfType, that feels a bit redundant to me if you've already internalized "caps == types".
More information about the swift-evolution