[swift-evolution] [Review] SE-0065 A New Model for Collections and Indices

Shawn Erickson shawnce at gmail.com
Thu Apr 14 01:23:35 CDT 2016

On Wed, Apr 13, 2016 at 4:45 PM Dave Abrahams via swift-evolution <
swift-evolution at swift.org> wrote:

Updated proposal:
> https://github.com/apple/swift-evolution/blob/master/proposals/0065-collections-move-indices.md

I like the use of `location(...)` instead of `index(...)`. I strongly
suggest that successor and predecessor become `location(after:)` and
`location(before:)` (or something like that) so that the index manipulation
API are all similarly named.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160414/fd78c942/attachment.html>

More information about the swift-evolution mailing list