100% Agree. IMO .isIn is perfect :-) I think the main idea is to allow us to check bounds of some value(usually integer) in nice and readable manner. On 08.04.2016 21:21, Dave Abrahams via swift-evolution wrote: > API guidelines prescribe this should read as an assertion about x, so: > > x.isContainedIn(0..<100) > > or > > x.isIn(0..<100)