[swift-evolution] [SR-933] Rename flatten to flattened
david at alkaline-solutions.com
Fri Apr 8 14:00:39 CDT 2016
> On Apr 8, 2016, at 4:19 AM, Haravikk via swift-evolution <swift-evolution at swift.org> wrote:
> If we want mutating forms of this methods then I much prefer .map() and .mapped() to .map() and .mapInPlace() or whatever, as the latter contradicts the naming convention used everywhere else which only adds confusion.
Strong -1 to recycling the meaning of 'map' or any of the others to be the mutating versions. That would make 'map' fundamentally different and even counter to the term of art
More information about the swift-evolution