[swift-evolution] [Review] SE-0059: Update API Naming Guidelines and Rewrite Set APIs Accordingly

Dave Abrahams dabrahams at apple.com
Thu Apr 7 17:16:05 CDT 2016

on Thu Apr 07 2016, Erica Sadun <erica-AT-ericasadun.com> wrote:

>> On Apr 7, 2016, at 2:34 PM, Dave Abrahams via swift-evolution <swift-evolution at swift.org> wrote:
>> on Mon Apr 04 2016, Xiaodi Wu <swift-evolution at swift.org> wrote:
>>> My read on the API guidelines is that the mutating/non-mutating distinction is
>>> made by verbs vs. nouns. The verb itself doesn't have to "suggest" or "feel"
>>> mutating, it just has to be clearly a verb. Thus, IMO, `form` is as good a verb
>>> as any, although if we're going to return to bikeshedding I would suggest that
>>> `do` is even shorter.
>> It is, but x.doUnion(y) doesn't make any plausible sense, at least not
>> to me.
> It's worth mentioning that there's still a fanbase for `union` and
> `unionInPlace`.

Noted.  I'm part of it.


More information about the swift-evolution mailing list