[swift-evolution] [Review] SE-0059: Update API Naming Guidelines and Rewrite Set APIs Accordingly
dabrahams at apple.com
Thu Apr 7 15:34:27 CDT 2016
on Mon Apr 04 2016, Xiaodi Wu <swift-evolution at swift.org> wrote:
> My read on the API guidelines is that the mutating/non-mutating distinction is
> made by verbs vs. nouns. The verb itself doesn't have to "suggest" or "feel"
> mutating, it just has to be clearly a verb. Thus, IMO, `form` is as good a verb
> as any, although if we're going to return to bikeshedding I would suggest that
> `do` is even shorter.
It is, but x.doUnion(y) doesn't make any plausible sense, at least not
More information about the swift-evolution