[swift-evolution] Feature proposal: Range operator with step

Erica Sadun erica at ericasadun.com
Tue Apr 5 17:04:34 CDT 2016


> On Apr 5, 2016, at 1:54 PM, Dave Abrahams <dabrahams at apple.com> wrote:
> IMO this:
> 
>  (-9...0).reverse()
> 
> is better than 
> 
>  stride(from: 0, to: -10, by: -1)
> 
> What do you think?

The latter better reflects an author's actual intent. The former depends on implementation details, which can be hazy, especially, around the edge cases. It is quicker to read, understand, and verify that the latter is what is meant.

-- E

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160405/663b2f2a/attachment.html>


More information about the swift-evolution mailing list