[swift-evolution] SE-0025: Scoped Access Level, next steps
mwhiteside.dev at gmail.com
Thu Mar 31 17:29:02 CDT 2016
> So, proposal one (and 1b), more technical sounding
> internal (or intramodule)
`intrafile` and `intramodule` sound esoteric to me.
I like these ones better:
private//aka, scopeonly? unfortunate that this isn’t automatically clear
Tino’s suggestion is also interesting:
visible(file, ModuleA, File.swift)
But I think the paren syntax suggested earlier is equivalent, and would be the clearest to both experienced and beginning developers:
If parens are a no-go, perhaps the following could work:
I’m not a huge fan of `fileprivate` or `moduleprivate`, because they seem like strange non-words.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution