[swift-evolution] SetAlgebra naming update
griotspeak at gmail.com
Tue Mar 29 17:07:37 CDT 2016
I think that this is a great improvement and is consistent enough to
accept. `form` will take some getting used to.
On Thu, Mar 24, 2016 at 9:39 PM, Dave Abrahams via swift-evolution <
swift-evolution at swift.org> wrote:
> Just an update:
> The naming guidelines working group went back into negotiation over
> the shape of SetAlgebra (and thus, Set and OptionSet) for
> Swift 3, and reached a new consensus. We intend to bring forward a
> proposal for the API shown here:
> and to update the guidelines to suggest using the "form" prefix to
> create a verb phrase for a mutating method when the operation is
> fundamentally non-mutating and described by a noun.
> swift-evolution mailing list
> swift-evolution at swift.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution