[swift-evolution] SetAlgebra naming update
erica at ericasadun.com
Thu Mar 24 16:05:41 CDT 2016
> On Mar 24, 2016, at 2:39 PM, Dave Abrahams via swift-evolution <swift-evolution at swift.org> wrote:
> Just an update:
> The naming guidelines working group went back into negotiation over
> the shape of SetAlgebra (and thus, Set and OptionSet) for
> Swift 3, and reached a new consensus. We intend to bring forward a
> proposal for the API shown here:
> and to update the guidelines to suggest using the "form" prefix to
> create a verb phrase for a mutating method when the operation is
> fundamentally non-mutating and described by a noun.
I've got to say, I expected to hate this until I clicked the link and saw the actual
proposed syntax. For the most part, it's good: clear and readable.
Not a fan of "subtracting" (would prefer "bySubtracting"). Other than that
really impressed by how this evolved.
More information about the swift-evolution