[swift-evolution] Proposal: change infix operator attributes syntax to be more consistent with the rest of the language

Radosław Pietruszewski radexpl at gmail.com
Sun Mar 6 15:55:36 CST 2016

I agree “infix operator” reads more naturally, but I find it a bit strange to split operator configuration into fixity prefix and other parameters in curly braces/parentheses.

— Radek

> On 06 Mar 2016, at 20:46, Kevin Lundberg via swift-evolution <swift-evolution at swift.org> wrote:
> Personally I like the current way of declaring an operator's expected "fixity" as it reads much more naturally:
> infix operator += // reads "an infix operator named +="
> when compared to 
> operator += (infix) 
> // or
> operator += (fixity: infix) // reads as "an operator named += which has a fixity of infix"

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160306/05a8d20a/attachment.html>

More information about the swift-evolution mailing list