[swift-evolution] [Proposal] Conventionalizing stride semantics
tseitz42 at icloud.com
Wed Mar 2 14:21:36 CST 2016
+1 from me as well
> Am 02.03.2016 um 15:34 schrieb Xiaodi Wu via swift-evolution <swift-evolution at swift.org>:
> Indeed! For me, the reverted syntax makes sufficient sense.
> On Wed, Mar 2, 2016 at 3:58 AM Brent Royal-Gordon <brent at architechies.com <mailto:brent at architechies.com>> wrote:
> >> So in other other words, the change from `stride(from: 1, to: 2, by: 0.1)` to `1.stride(to: 2, by: 0.1)` is the source of the problem and should be reversed.
> > It is reversed in SE-0006.
> Wow, as of seven days ago. That's a very pleasant surprise (and one that's probably relevant to this thread).
> Brent Royal-Gordon
> swift-evolution mailing list
> swift-evolution at swift.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution