[swift-evolution] Rename 'guard' to 'ensure'

Andrew Duncan andrewzboard at gmail.com
Thu Feb 25 19:38:25 CST 2016

Apart from Shawn’s (dispositive) point about Ensure™, the word sounds more (to me) like a POSTcondition... which apparently B. Meyer also thought when designing Eiffel.

Now, wouldn’t it be nice to have co/contravariant assertions... oops, different thread. Not going there.

More information about the swift-evolution mailing list