[swift-evolution] [Discussion] Naming directives

Vanderlei Martinelli vmartinelli at alecrim.com
Thu Feb 25 14:48:38 CST 2016

Well... I think that there is nothing wrong with the current directives
*and* attribute names being lowercase (with some exceptions for attributes
when relating to Objective-C/Cocoa support).

One of the things I dislike in Java is the @Override. First the `override`
should no be an attribute, but since it is, `@override` would be much more

The same goes for directives that is what is being discussed here. I vote
for lowercase.


On Thu, Feb 25, 2016 at 5:31 PM, Антон Жилин <swift-evolution at swift.org>

> Exceptions from guidelines probably can happen, given an argumentation. In
> attributes, @NS- and @IB- things for compatibility with Objective-C. Here,
> #elseif for analogy with "else if" in usual Swift. #elseIf also feels odd
> to me.
> Can #end be a better name for #endif?
> Anyway, I think I won't create a proposal draft until the proposals
> containing mentioned directives get accepted.
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160225/9abf1e49/attachment.html>

More information about the swift-evolution mailing list